Career sites is not available

Minor incident Emply Hire (V1)
07-04-2025 08:00 CEST · 2 hours, 8 minutes

Updates

Issue

Career sites is currently not available.

We are working on a solution.

April 7, 2025 · 09:11 CEST
Resolved

Career sites are now accessible.

Sorry for the inconvenience.

April 7, 2025 · 09:00 CEST

← Back