Unable to download Emply app

Minor incident Emply
25-05-2025 13:08 CEST · 2 weeks, 3 days, 2 hours, 5 minutes

Updates

Resolved

It’s now possible to download the app again.

June 11, 2025 · 15:11 CEST
Issue

Some users may not be able to download the Emply app.
Our team is working on finding the cause.

June 2, 2025 · 13:08 CEST

← Back