Service Update: Reduced Emply Performance for Certain Users

Minor incident Emply
17-02-2026 14:55 CET · 21 hours, 31 minutes

Updates

Resolved

.
We can confirm that the earlier performance issues in Emply have now been resolved. The system is operating as expected again, and users should no longer experience delays.

Thank you for your patience while we worked to fix the issue.

February 18, 2026 · 12:25 CET
Investigating

.
We can confirm that the earlier performance issues in Emply have now been resolved. The system is operating as expected again, and users should no longer experience delays.

Thank you for your patience while we worked to fix the issue.

February 18, 2026 · 12:20 CET
Update

.
Some users might still experience slower-than-usual performance in Emply. The good news is that we expect performance to improve during the morning.

Our team is actively working on the issue. We will share an update as soon as everything is fully back to normal.

Thank you for your patience.

February 18, 2026 · 07:51 CET
Issue

.
We are currently seeing slower-than-usual performance in Emply, affecting some users. This may result in delays when loading pages or using certain features.

Our team is working to resolve the issue as quickly as possible, and we will share an update as soon as everything is back to normal.

Thank you for your patience.

February 17, 2026 · 14:55 CET

← Back