Penneo‑Signed documents not updating in Emply

Incident Emply
19-03-2026 10:56 CET · 1 month, 5 days, 2 hours, 34 minutes

Updates

Resolved

.
The issue where documents signed in Penneo were not being updated correctly as signed in Emply People has now been resolved. Signed documents are once again reflected correctly in Emply, and related notifications are being delivered as expected.

We will continue to monitor the integration to ensure stable operation.
Thank you for your patience while we worked to resolve this issue.

April 23, 2026 · 14:27 CEST
Issue

.
We are currently experiencing an issue where documents sent to Penneo for signing are not being correctly reflected as signed in Emply. This means that even after a document has been signed in Penneo, it may still appear as unsigned in Emply. In some cases, users are also not receiving the expected sign request notifications.

Our team is actively investigating the issue to identify the cause and work toward a resolution.

Thank you for your patience.

March 19, 2026 · 10:56 CET

← Back