Career Site Phone Field Not Loading Correctly

Incident Emply
19-03-2026 11:11 CET · 1 month, 5 days, 1 hour, 56 minutes

Updates

Resolved

.
The issue affecting the phone number field on the Career Site has been resolved. The field now loads and behaves correctly without requiring manual selection or entry of a country or country code.

Candidates should now be able to complete and submit their application forms as expected. We will continue to monitor the solution to ensure stability.

Thank you for your patience while we worked to resolve this issue.

April 23, 2026 · 14:02 CEST
Issue

.
We are experiencing an issue on the Career Site where the phone number field requires users to manually enter the country or country code (for example, selecting Denmark or typing +45) before the field behaves correctly. If the country code is not manually entered or selected, the field may remain inactive or fail to populate, which prevents candidates from submitting their application form.

We are working on resolving this and appreciate your patience while we address the issue.

March 19, 2026 · 11:11 CET

← Back