Identified – General Slow Performance in Emply

Incident Emply
08-04-2026 15:20 CEST · 1 hour, 39 minutes

Updates

Resolved

.
The issue causing slow performance in Emply has been resolved. All services, including loading times and import/export operations, are now operating normally.

We appreciate your patience and apologize for any inconvenience caused

April 8, 2026 · 16:58 CEST
Issue

.
We are currently experiencing general slow performance across Emply. This may affect loading times and import and export operations.

Our team is actively working on a fix to restore normal performance as quickly as possible.

We apologize for the inconvenience and will provide further updates as progress is made.

April 8, 2026 · 15:20 CEST

← Back