Investigating Slow Performance on Emply People
Incident
Emply
23-04-2026 09:34 CEST
· 3 hours, 41 minutes
Updates
Resolved
April 23, 2026 · 13:14 CEST
.
The issue causing slow performance on Emply People earlier this morning has been resolved. Performance has returned to normal, and we continue to monitor the platform closely.
Thank you for your patience.
Investigating
April 23, 2026 · 09:34 CEST
.
We are currently experiencing slow performance on Emply People this morning.
Our technical team is investigating the issue and working to restore normal performance as quickly as possible.
We will continue to provide updates, and we appreciate your patience.
← Back