Ongoing Issue: Delayed Emails

Incident Emply
12-05-2026 09:12 CEST · 4 weeks, 1 day, 7 hours, 34 minutes

Updates

Update

.
We are making progress and actively working on a fix to address the identified performance challenge.
Efforts are currently focused on stabilizing system behavior during peak hours (08:00–12:00) and improving the processing of:

  • Message service operations
  • Data exports and other background jobs
  • User/Employee‑initiated system tasks

Mitigation measures are being implemented alongside continued root‑cause analysis.

We will share further updates as improvements are rolled out.

May 27, 2026 · 11:03 CEST
Issue

.
We continue to experience delays in email delivery.

Our investigation shows that delays occur during peak traffic hours, particularly between 08:00 and 12:00, when system load is highest.

Our team is actively working to further analyze the root cause and implement measures to resolve the issue.

We will continue to share updates as progress is made.

Thank you for your patience.

May 12, 2026 · 09:12 CEST

← Back