Emply People Performance Delays Across Functions
Incident
Emply
15-05-2026 09:43 CEST
· 2 hours
Updates
Resolved
May 15, 2026 · 11:43 CEST
.
The previously reported slow performance in Emply People affecting multiple functions has now been resolved. Performance has returned to normal, and workflows, exports, and processing are operating as expected.
Thank you for your patience while we worked on resolving this. We will continue to monitor to ensure stability.
Issue
May 15, 2026 · 09:43 CEST
.
We are currently experiencing slow performance in Emply People, which can affect multiple functions. This is resulting in workflow, export, and processing delays.
We are actively investigating the issue and working to restore normal performance.
← Back