Performance Delays
Incident
Emply
18-05-2026 08:51 CEST
· 1 day, 23 hours, 44 minutes
Updates
Investigating
May 20, 2026 · 08:11 CEST
.
The performance issues affecting Emply People have now been resolved. System functionality, including workflows, exports, and processing, has returned to normal.
We appreciate your patience while we investigated and resolved the issue. If you continue to experience any unexpected behavior, please don’t hesitate to reach out to support.
Investigating
May 18, 2026 · 08:51 CEST
.
We are currently experiencing slow performance in Emply People, which can affect multiple functions. This is resulting in workflow, export, and processing delays.
We are actively investigating the issue and working to restore normal performance.
← Back